System Requirements


All BannerOS Grips require a valid BannerOS license. BannerOS installs directly on your Website and requires a compatible Web host. Since the product runs on the LAMP (Linux, Apache, MySQL, PHP) stack, it's compatible with a high percentage of Website hosts. It hasn't been tested, but may also work in WAMP (Windows, Apache, MySQL PHP) and WIMP (Windows, IIS, MySQL, PHP) environments.

In case your Website is hosted at an incompatible host, BannerView.com can provide hosting for your Website, email and BannerOS in a single location.

System Specifications:

Modern Web browser recommended – latest versions of Chrome, Firefox, Internet Explorer, Opera, Safair, etc. which supports JavaScript, cookies, and cascading style sheets running on any Operating System.

Server Software:

  • Apache Version 2.0 or Above
  • PHP Version 5.3.x tree, 5.4.x tree 5.5.x tree or 5.6.x tree
  • Zend Guard Loader supporting the installed PHP version – requirements can be found here: http://www.zend.com/en/products/zend-guard#requirements
  • The following PHP Modules: mcrypt, json, gd, curl, mbstring, mysql & mysqli, uploadprogress.so is optional
  • MySQL Version 5.5 or Above
  • Access to Cron Jobs
  • MaxMind Geo IP Database for looking up visitor locations based upon IP addresses (optional)
  • ImageMagick (Optional)
  • Add support for .bv file extensions. Configure Apache to treat .bv files the same as regular PHP files